This project is read-only.

Cannot link to my pages in subdirectory

Topics: Developer Forum, Project Management Forum, User Forum
Apr 28, 2007 at 4:14 PM
I have got some project under subfolder, for example, photoalbums. Suppose I have a main aspx page there as main.aspx. Before I put the portal there, everything is running smooth. After I deployed the portal in root directory, and created gallery page that is linked to photoalbums/main.aspx, now main.aspx is not working any more. It checks web.config, showed errors as:
===============
Could not load type 'MyWebPagesStarterKit.Providers.CustomRoleProvider'
Source Error:
Line 50: <providers>
Line 51: <clear/>
Line 52: <add name="CustomRoleProvider" type="MyWebPagesStarterKit.Providers.CustomRoleProvider"/>
Line 53: </providers>
Line 54: </roleManager>
===========
I didn't see dlls in the bin directory after I deployed the portal. It seems to me that the dll that contains the MyWebPagesStarterKit.Providers.CustomRoleProvider is not there. What is the problem? Does the downloaded version contains necessary compiled dlls? Or we have to create projects and build these dlls? How to resolve this issue to make sure my own pages are working? thanks!
May 4, 2007 at 3:23 PM
Dear user
since it is a asp.net 2.0 website, there are no dlls anymore. So don't worry about that. the website should be working as long as the webserver is configured correctly..
did you read the installation guide ? \Documentation\en\installation_guide.html

Best regards,
webeasy