FCKLang is undefined in

Topics: Developer Forum, Localization Forum, Project Management Forum, User Forum
Jan 18, 2009 at 6:40 AM
Edited Jan 18, 2009 at 6:44 AM
I've been through all the discussions, tried all the suggestions that came close the what the problem is with FCKEditor and FCKLang, yet I still can't seem to get this problem resloved.
I can edit the HTML sections using Visual Web Developer,
but going through Internet Explorer I keep coming up with:

Line: 22
Char: 1500
Error: Permission Denied
Code: 0
URL: http://mydomain/FCKeditor/editor/FCKeditor.html/?
         instancename=ctl00_mainContent_ctl05_FCKeditor1&Toolbar=customized

Line: 80
Char: 177
Error: 'FCKLang' is undefined
Code: 0
URL: http://mydomain/FCKeditor/editor/FCKeditor.html/?
         instancename=ctl00_mainContent_ctl05_FCKeditor1&Toolbar=customized

Line: 97
Char: 1
Error: 'FCKLang' is undefined
Code: 0
URL: http://mydomain/FCKeditor/editor/FCKeditor.html/?
         instancename=ctl00_mainContent_ctl05_FCKeditor1&Toolbar=customized

Line: 73
Char: 2691
Error: 'FCKLang' is undefined
Code: 0
URL: http://mydomain/FCKeditor/editor/FCKeditor.html/?
         instancename=ctl00_mainContent_ctl05_FCKeditor1&Toolbar=customized


I've had this problem since ver. 1.0
I've recently updated to 1.2.1 and still have the same problem
Initial setup, I selected English US, and any file with a list of languages, I placed "en" at the top of the list of the selection provided.


is this an IE Problem, or is there more for me to do in the editing??

I just placed all the files from ver. 1.2.2 and still have the same problem
I hadn't changed anything in the files, so now I'm thinking it may be IE 7

any help is greatly appreciated.

Thank you,

Ed
Jan 18, 2009 at 10:06 PM
what servers are you uploading the site to i had the same problem once i uploaded the files to my online server being go daddy. once looking at the files on the server i noticed that the fck folder only uploaded partially i had to uplaod each file (in that folder only) one by one then it worked fine.
Jan 19, 2009 at 2:29 AM
RNM1455

I'm using my own IIS server under Windows XP Pro

I've had this problem from the beginning, and have never had a response with previous posts.
I can edit HTML with Visual Web Developer in debugging, or from my computer name or localhost access

Through my domain name, I can't do any HTML editing., though; I'd like to be able to do this from other computers instead of having to work directly on my web server.
Everything else in the starter kit works fine; it's just this one thing that doesn't work for me through IE.

I've uploaded to hosts before, and there's nothing but problems; from the simplest HTML to all the web programming, and having to work around all their issues - I decided to host my own domain just to bypass all the hassle of the support people, customer service, and tech support of the hosting servers. I get a better response when I can see the problem on my own, instead of waiting for answers from others.

Thanks,

Ed
Jan 28, 2009 at 5:47 PM
Problem figured out.   Any fix around working on the issue of being able to edit the HTML within frames?????

I'm working with a Dymanic IP, so I need a redirect from a DNS hosting company; they use frames for URL Masking, so the links within the page won't work for editing.
When I turn off the masking I can edit my HTML sections in the web site (unfortunately my address becomes my IP instead of my domain.
Oct 24, 2009 at 6:59 PM
ed82264 wrote:
Problem figured out.   Any fix around working on the issue of being able to edit the HTML within frames?????

I'm working with a Dymanic IP, so I need a redirect from a DNS hosting company; they use frames for URL Masking, so the links within the page won't work for editing.
When I turn off the masking I can edit my HTML sections in the web site (unfortunately my address becomes my IP instead of my domain.

I was running into the same exact problem. I'm glad this post was here. But my solution was, instead of turning off masking, to use my unmasked site URL to edit. Using http://Art-by-Barbara.com didn't work, so I use http://netein.com/Art-by-Barbara instead. Works just find. A little less appealing, but more appealing then masking the URL. Thanks again!