Gridview sort not working

Topics: Developer Forum, Localization Forum, Project Management Forum
Oct 23, 2008 at 7:00 PM
Hello and thanks for a great tool. I have an issue with gridview sorts not working. I am adding user controls to the EasyControls folder. These controls consist of gridviews. The "Allow Sorting" is set to true. I have added an express database and I am using sqldatasources as the data source. The gridviews work fine in all other ways except when added to a page the sort is not available. The under-line is not there. In the gridview the SortExpression is set the datafields correctly.  Any help would be great. Also why can I not save the connection string in the Web Config file?
Oct 23, 2008 at 7:53 PM
I am also having the same problem with an access database and the accessdatasource. The column headings are underlined in design view of visual web developer, but not when displayed on the page through the easy control. Any help is greatly appreciated.
Oct 23, 2008 at 9:49 PM
have a look to your skin file: 

<

 

asp:GridView runat="server" AllowPaging="true" AllowSorting="true" BorderStyle="none" BorderWidth="0px" Width="100%" GridLines="none"></asp:GridView>


I've set AllowSorting and AllowPaging to true and voila...

 

Oct 23, 2008 at 10:19 PM

I cannot find a skin file, where is it located? And what setting in the skin file am I looking for?

NOTICE OF CONFIDENTIALITY

The information contained in this communication, including but not limited to any accompanying document(s) and/or attachment(s), is privileged and confidential and is intended solely for the above-named individual(s). If you are not the intended recipient, please be advised that any distribution, copying, disclosure, and/or use of the information contained herein is strictly prohibited. If you received this communication in error, please destroy all copies of the communication, whether in electronic or hard copy format, and immediately contact the sender and notify him/her about the error.

Thank you.

Oct 23, 2008 at 10:43 PM

I Got IT! I found the skins in the Themes Folder and made the change for the gridview. That did it! Thanks very much.