Issue: FCK Editor wont upload images

May 26, 2010 at 3:33 PM
Edited May 26, 2010 at 4:26 PM

Hi Everyone,

This is the first time I've encountered this while building a website. I've created a site and made it live and now when I try making edits it's not showing any files uploaded through the Image properties browse server option.

And when I try to upload a file to the server it just forever tries to load the image file and nothing happens.

Has anyone encountered this before and if so what did you do? The strange thing is that this was working fine when I was testing it in a test folder on the hosting before moving the site to the root.

This is the code of one of the images.
<img hspace="5" height="82" border="0" align="left" width="82" vspace="8" alt="Female teacher with a group of students" src="ImageHandler.ashx?UploadedFile=true&amp;pg={0}&amp;image=App_Data/UserImages/img_donate_1a.png" />

What's strange is it shows the images but on the editing end it shows a red x and I can't view any files through the Browse server option and if I wanted up load a new photo I can't.

This is the error that just popped up when accessing the Browse server option.

"The sevrer didn't reply with proper XML data. Please check your configuration"  This is strange becasuse I haven't changed any configuration other than setting IIS permissions for the site to be viewable.

:(

Thanks for any help

May 26, 2010 at 10:14 PM
Edited May 26, 2010 at 10:22 PM

Hello Uptown Girl, You will have a very nasty security issue if you have modified your permissions for anything but the App_Data folder!

The only setting's you should need to adjust are the permissions for the App_Data folder as follows.

Inherit = false (Inherit permissions from parent directory)  
Read = true (Directory contents are visible to users)  
Write = true (Applications can write to this directory)  
Reset all children to inherit = true (All subdirectories will be reset to inherit from current directory)

Just from what you have described it sounds like this should hit the nail straight on :-)

Also note that the permissions I have stated will not allow a user to navigate to the App_Data folder as IIS will just deny it! Hence the reason all our personal details are stored there.

Regards

May 27, 2010 at 2:41 PM
Edited May 27, 2010 at 3:29 PM

Hi SpiderMaster,

Ok I will try what you said and see what happens. I didn't realize that setting the permissions a certain way could cause this problem. I'll let you know what happens.

Thanks!

 

May 27, 2010 at 3:32 PM

Update:

I fixed the security issue. Still haven't resolved why the images aren't showing through edit mode, and no images show when I browse server and why I can't upload images. Still troubleshooting this.

Also I noticed that there's a caution icon on my browser bar saying that Permission Denied for accessing file upload.aspx

here's a portion of the url path
/FCKeditor/editor/filemanager/connectors/aspx/upload.aspx?Type=Image

Still scratching my head on this one :(

May 27, 2010 at 5:30 PM

I would suggest downloading the latest version of MWPSK, MWPSK no longer supports the FCK Editor!

Not only that the FCK Editor is no longer and is now just CK Editor, If you wish to keep using this in your application then you could all ways get help from http://ckeditor.com/ and http://mwpskcontrib.codeplex.com/

Wish I could be more help :-)

May 28, 2010 at 3:57 PM

As much as I love the MWPSK package this is definitely the one downside to it, but I wouldnt stop using it because of this.  My simple solution to the problem is that I use a free HTML editor (www.coffeecup.com) on my local computer then just copy the code over.  Easy Breezy and works like a charm.  I know this isnt the ideal situation, but it works and keeps me in business.  Outside of that I love MWPSK and would keep recommending it to everyone I know.