MWPSK on Brinkster (with free developer account)

Dec 22, 2009 at 10:44 PM
Edited Dec 22, 2009 at 10:49 PM

Hi

I was unable to create MWPSK site on brinkster.com.

I have free developer pack which has support for:

http://www.brinkster.com/hosting/FreeDeveloper.aspx

 

Reading that page I noticed they mentioned support for asp.net (but they didn't write which version is supported), so as MWPSK is written in asp.net v2.0 I'm interested is somebody maybe was successful in starting site on brinkster with free developer account.

I manage to create directory structure on brinkster server, i uploaded compiled solution, but there was no help with all of that because he always give me same message which you can see on http://triper2u.brinkster.net/.

Web.config content: - on my local site (cassini and iis 7.5) it works without problems,; on  brinkster it generates error.

 

<?xml version="1.0"?>
<configuration>
    <configSections>
        <section name="supportedLanguages" requirePermission="false" type="System.Configuration.SingleTagSectionHandler"/>
    </configSections>
    <appSettings>
        <add key="version" value="1.3.0"/>
    </appSettings>
    <connectionStrings/>
    <supportedLanguages languages="en"/>
    
    <system.web>
        <httpRuntime maxRequestLength="102400" />
        <compilation debug="false" batch="true">
            <assemblies>
                <add assembly="System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
            </assemblies>
        </compilation>
        <authentication mode="Forms">
            <forms loginUrl="Login.aspx" timeout="500000"  protection="All" name=".ASPXFORMSAUTH"/>
        </authentication>


        <!--
        Make sure that upon deployment, this setting may have to be commented out as most
        providers/hosters don't allow you to manually set the trust level.
        -->
        <!-- <trust level="Medium" originUrl=".*"/>-->

        <customErrors mode="Off" defaultRedirect="GenericErrorPage.htm">
            <error statusCode="403" redirect="NoAccess.htm" />
            <error statusCode="404" redirect="FileNotFound.htm" />
        </customErrors>

        <membership defaultProvider="CustomXmlMembershipProvider">
            <providers>
                <clear/>
                <add name="CustomXmlMembershipProvider" type="MyWebPagesStarterKit.Providers.CustomXmlMembershipProvider" maxInvalidPasswordAttempts="3" passwordAttemptWindow="5" minRequiredNonAlphanumericCharacters="0" minRequiredPasswordLength="3" passwordStrengthRegularExpression="" enablePasswordReset="true" enablePasswordRetrieval="true" requiresQuestionAndAnswer="True" requiresUniqueEmail="true"/>
            </providers>
        </membership>
        <roleManager defaultProvider="CustomRoleProvider" enabled="true">
            <providers>
                <clear/>
                <add name="CustomRoleProvider" type="MyWebPagesStarterKit.Providers.CustomRoleProvider"/>
            </providers>
        </roleManager>
        <siteMap defaultProvider="CustomXmlSitemapProvider">
            <providers>
                <clear/>
                <add name="CustomXmlSitemapProvider" type="MyWebPagesStarterKit.Providers.CustomXmlSitemapProvider" securityTrimmingEnabled="true" siteMapFile="~/App_Data/Web.sitemap"/>
            </providers>
        </siteMap>
    </system.web>
    <location path="Administration">
        <system.web>
            <authorization>
                <allow roles="Administrators"/>
                <deny users="*"/>
            </authorization>
        </system.web>
    </location>
</configuration>

Any help will be usefull!!

 

Dec 23, 2009 at 3:34 AM

The Error Message is quite clear! The Application is not in the ROOT of IIS therefore IIS needs to be configured to recognize your install as a valid IIS Application.

You simply can not do without purchasing hosting with brinkster.

Brinkster has asp.net 3.0 it is clear on there sign up page for the hosting you have!!!

Dec 23, 2009 at 8:19 AM
SpiderMaster wrote:

The Error Message is quite clear! The Application is not in the ROOT of IIS therefore IIS needs to be configured to recognize your install as a valid IIS Application.

You simply can not do without purchasing hosting with brinkster.

Brinkster has asp.net 3.0 it is clear on there sign up page for the hosting you have!!!

Yes, you're right. But I knew that brinkster has .net 3.0/3.5 for commercial accounts, question was for FREE accounts.

I didn't be enough careful with page reading and I assume that root folder will be automatically configured as root for (valid) application .

Few infs for newbies (from brinkster helpdesk) which I dig this morning : https://help.brinkster.com/KB/root.aspx

 

Between lines:


1. All of your .NET code must be written in-line. This means that you must put all of your .NET code (VB.NET, C#, etc) in the .aspx file (or .asmx, .ascx, etc).

2. You do not have the use of any of the following:
• web.config (specifically for application level configurations)
          • Global.asa
          • bin directory

          • A web.config file can be used to configure non-application level items such as custom errors. 
          Example: " <customErrors mode="Off"/> "

Can I use ASP.NET v1.1, v3.0 or v3.5?
No, our free servers only support ASP.NET 2.0. The paid accounts that offer ASP.NET support have 1.1, 2.0 and 3.5.

 

Does maybe somebody know some other relatively good but free hosting which can run MWPSK ?