This project is read-only.

Configuration Error when installating at a shared hoster

Topics: Developer Forum
Dec 11, 2006 at 6:50 PM
Works nicely on my Visual Web Developer, but I copied the files at my hoster, and got a fatal error at startup:

Parser Error Message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS.

Source Error:
Line 17: </compilation>
Line 18: <authentication mode="Forms">
Line 19: <forms loginUrl="Login.aspx" timeout="500000" protection="All" name=".ASPXFORMSAUTH" />
Line 20: </authentication>

Source File: web.config, line 18.

I configured the vdir as an application, the hoster's control panel (PLESK 7.6.1) loads correctly some input from the config file (custom error pages for instance), but fails on the authentication mode. What do I need to do to have the kit work ?
Dec 12, 2006 at 11:23 AM
Hello

This error may occur if the application is being run out of a subfolder that is not configured in IIS to run as an application, or if the application uses shared SSL and the secure location has not been configured to run as an application. To resolve the error, contact your host and ask them to configure the subfolder or secure location to run as an application according to the instructions below.

To configure a subfolder to run as an application in IIS:

1. On the server where the site is hosted, click on the Start menu and select Settings, then Control Panel. Open the Internet Services Manager.


2. Locate the subfolder or virtual directory and right-click on it. Choose Properties.


3. Open the Directory tab and click Create. Set Execute Permissions to "Scripts only."


4. Click OK, then click Apply.

If you need further assistance, let me know!

Best regards,
Pascal