Copy webserver to new URL

Topics: Developer Forum, User Forum
May 31, 2010 at 10:25 PM
Edited Jun 16, 2010 at 4:41 PM

Hello,

I have been trying to copy an existing site to a new URL, and have been mostly sucessful, except when I try to log into the admin account.

I am using IIS7, on a windows 2008 server.

Has anyone else runinto this migration problem? Any sugrstions?

I get the following error when i log in after migrating an existing My Web Pages Starter Kit to a new web address and try to login as admin:

Internet Information Services 7.0

<fieldset><legend>Error Summary</legend>

HTTP Error 404.0 - Not Found

The resource you are looking for has been removed, had its name changed, or is temporarily unavailable.

</fieldset>
<fieldset><legend>Detailed Error Information</legend>
Module IIS Web Core
Notification MapRequestHandler
Handler StaticFile
Error Code 0x80070002
Requested URL http://siteurl.com:80/GenericErrorPage.htm?aspxerrorpath=/Login.aspx
Physical Path E:\wwwroot\siteurl.com\GenericErrorPage.htm
Logon Method Anonymous
Logon User Anonymous
</fieldset>
Jun 15, 2010 at 2:37 AM

I have this same issue, were you able to resolve it?

Jun 15, 2010 at 3:05 PM

Same issue, any help would be aprreciated...

Jun 16, 2010 at 11:00 AM

Make sure your App_Data Folder is writeable. If the ASP user has no write privileges on that folder, the login will fail.

Jun 16, 2010 at 4:42 PM
I haven't found a solution yet, but I will look at nodo's suggestion
Jun 16, 2010 at 5:31 PM
Hi nodo, I looked at your suggestion, but it looks like all the permissions are the same from the original site to the moved new url site.
Jun 28, 2010 at 5:40 AM

Hello all, here is a modified post from [discussion:217472]

If you are getting an error then it is best you publish the complete error (set custom Errors to 'Off' in the web config) so that the community can help you, this includes the Asp.Net Version at the bottom of an error page and a detailed report on the issue at hand.

Some steps to check (assuming that this is hosted with your privileges being a Maximum of Medium Trust)

  1. Ensure that IIS has Read/Write permissions for the App_Data folder.
  2. Ensure that IIS is at least version 6 (IIS6) IIS7 is recommended.
  3. Check your hosting control panel to see if .Net 4.0 is enabled, Normally this will be pre-set at .Net 2.0 or .Net 3.0 and some hosters are still slack at getting updated.
  4. Check every project in your solution and ensure that it Targets .Net 4.0 as I have found with some of my compiled assembly's still targeting .Net 3.5 or even .Net 3.0, if .Net 3.0/3.5 is not installed I get some very interesting behaviour and have had to update these assembly's to target .Net 4.0

If the above is no good then please post your full error and set-up configuration (example IIS6 on Windows Server 2003 with '.Net 2.0' and '.Net 4.0 Extended' and so on)

If you do get this working in the mean time please do post your steps on how you corrected this issue to better help others :-)

Please also remember there are numerous service packs to the .Net Frameworks and Hosters generally wont have these updated and can also cause such errors to be occurring.