Translation into NORWEGIAN

Topics: Developer Forum, Localization Forum
Jan 23, 2008 at 8:57 PM
Are there anyone who has stared with translation into Norwegian ??

Laffern
Jan 24, 2008 at 6:17 PM
http://www.itmannen.no/files/StringsRes.no.zip
I have not translated the documentation.

Hope this is good, it was done in a hurry.
Jan 24, 2008 at 8:30 PM
Hi mattb77!!

I've translated some of it already, but I can do some comparing on both of the translations nd merge it to one complete resource file.

I don't know if you has any problems using the resoure file after adding it to the project file. I sure do have had a lot of problems. Maybe you can point me in the correct direction.......

My translation is done in the default resource file because I can not figure out how I am introducing the new resource file to the starter kit.
I have tried to create resource file named StringRes.nb.resx, StringRes.nb.no.resx, StringRes.nb-no.resx and StringRes.no.resx with settings in the web.config for the key supportedLanguages as nb,nb-NO,nb-no,no etc.
But there is no way that I can get the application to use the norwegian language. In addition I have checked the ASP temp directory and the norwegian directory is creted and everything lokks perfect.
Any ideas ???

Laffern
Jan 25, 2008 at 5:16 PM
Hi Laffern.
Looks like we have the same challenge :/ But I will continue the search for a solution. If I find it, I will post it here.
Coordinator
Feb 1, 2008 at 2:09 PM
hi there !

When you take the TwoLetterISOLanguageName nb you get the language. In order to make the resource files work, you should name the resource files also with the code: nb

it just worked fine when I was testing it,
please let me know, if it works for you too!

webeasy
Feb 3, 2008 at 3:53 PM
Hi there again !!

By setting the language to nb makes it possible to select Norwegian (bokmål), but if a create a new resource adds it to the project naming it either StringRes.nb.resx or StringRes.no.resx I've only get the default language (English).
The best I could do (AND IT WORKS) was downloading Matb77 resource file in addition to add nb to the selecetelanguage tag in the web.config and select "Norwegian (Bokmål)" in the administrators' cms section.

If someone can tell me what I am doing wrong it would be nice :-).

Matb77 I am comparing your translation against mine. I'll post back here when I am done. ok?

Laffern
Coordinator
Feb 4, 2008 at 9:40 AM
Hi Laffern

The problem is, that there is no CultureInfo with the LanguageCode "no". (e.g. "en-US" -> English (USA)

I found these two entries for Norwegian:
nb-NO Norwegian (Bokmål)
nn-NO Norwegian (Nynorsk)

so it looks as if there are two types of Norwegian language....

when you put nb,nn int the web.config it will match the resource file from mattb77.

Best regards,
webeasy
Feb 4, 2008 at 3:56 PM
Edited Feb 4, 2008 at 3:57 PM
Hi there!

I tried the same approach as Laffern and it works fine for me.
I have made some changes in the resourcefile to, http://www.itmannen.no/files/StringsRes.no.zip.

BTW: this is the first time i have made an website in .net.
MWPSK is a great startingpoint.
I usually work in DW, but on this project i have been working in Visual Web Developer 08.
A little uncommon in the begining, but manageable and a great tool i think.
This is how the project looks so far, its for a friend of mine. http://www.kantenstrek.no. - Doesn't work all correct in safari/ie6 yet :/

Would appreciate any comments on that one.

MattB
Coordinator
Feb 7, 2008 at 9:44 AM
Hi MattB

There is an open issue about the safari problem at:
http://www.codeplex.com/MyWebPagesStarterKit/WorkItem/View.aspx?WorkItemId=13729

When you like, we can publish your website on the section "Websites based on MWPSK":
http://www.codeplex.com/MyWebPagesStarterKit/Wiki/View.aspx?title=Websites%20based%20on%20My%20Web%20Pages%20Starter%20Kit&referringTitle=Learn

Just let us know !

thanks and best regards,
webeasy