help me

Topics: Developer Forum, Localization Forum, Project Management Forum, User Forum
Dec 29, 2007 at 8:53 AM
see my web site at http://www.leonforteonline.it/spacesicily/portale_sicilia/

here is the web.config code:
<?xml version="1.0"?>
<configuration>
<configSections>
<section name="supportedLanguages" requirePermission="false" type="System.Configuration.SingleTagSectionHandler"/>
</configSections>
<appSettings>
<add key="version" value="1.1.4" />
<add key="FCKeditor:UserFilesPath" value="~/App_Data/UserImages/" />
<add key="portale_sicilia" value="1" />
</appSettings>

<connectionStrings/>

<!--<supportedLanguages languages="de,en,pt,ar,cs,es,pl,fr,el"/>-->

<system.web>

<httpRuntime maxRequestLength="100240" />

<compilation debug="true" batch="true">
<assemblies>
<add assembly="System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
</assemblies>
</compilation>

<authentication mode="Forms">
<forms loginUrl="Login.aspx" timeout="500000" protection="All" name=".ASPXFORMSAUTH"/>
</authentication>

<!--
Make sure that upon deployment, this setting may have to be commented out as most
providers/hosters don't allow you to manually set the trust level.

<trust level="Medium"/>
-->

<customErrors mode="Off" defaultRedirect="GenericErrorPage.htm">
<error statusCode="403" redirect="NoAccess.htm" />
<error statusCode="404" redirect="FileNotFound.htm" />
</customErrors>

<membership defaultProvider="CustomXmlMembershipProvider">
<providers>
<clear/>
<add name="CustomXmlMembershipProvider" type="MyWebPagesStarterKit.Providers.CustomXmlMembershipProvider" maxInvalidPasswordAttempts="3" passwordAttemptWindow="5" minRequiredNonAlphanumericCharacters="0" minRequiredPasswordLength="3" passwordStrengthRegularExpression="" enablePasswordReset="true" enablePasswordRetrieval="true" requiresQuestionAndAnswer="True" requiresUniqueEmail="true"/>
</providers>
</membership>
<roleManager defaultProvider="CustomRoleProvider" enabled="true">
<!--cacheRolesInCookie="true" cookieName=".ASPROLES" cookieTimeout="30" cookiePath="/" cookieRequireSSL="false" cookieSlidingExpiration="true" cookieProtection="All"-->
<providers>
<clear/>
<add name="CustomRoleProvider" type="MyWebPagesStarterKit.Providers.CustomRoleProvider"/>
</providers>
</roleManager>
<siteMap defaultProvider="CustomXmlSitemapProvider">
<providers>
<clear/>
<add name="CustomXmlSitemapProvider" type="MyWebPagesStarterKit.Providers.CustomXmlSitemapProvider" securityTrimmingEnabled="true" siteMapFile="~/App_Data/Web.sitemap"/>
</providers>
</siteMap>
</system.web>
<location path="Administration">
<system.web>
<authorization>
<allow roles="Administrators"/>
<deny users="*"/>
</authorization>
</system.web>
</location>
</configuration>
please help me