This project is read-only.

Error running locally

Topics: Developer Forum
Oct 23, 2007 at 6:02 PM
I am getting the following error related to the web.config file:

Error 3 It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS

anyone know how to resolve this? I have made no changes to the code at all. Thanks
Oct 30, 2007 at 9:40 AM

This happens, when you put the kit in a subfolder of your website root:

-- separate folder for mwpsk
-- -- the actual kit-files (including web.config)

The cause of the error is the web.config file, which contains some settings, that are only allowed to be made inside the web.config at root-level.

There are two solutions for this issue:
1) put the kit directly into your root folder
2) configure the subfolder as a virtual directory and give it its own application context (in IIS settings for the virtual directory go to the tab "directory" and near "application settings" click the "create" button. This should give the kit its own application context.