This project is read-only.

Server Error in '/' Application

Topics: Developer Forum, Project Management Forum, User Forum
Aug 5, 2007 at 6:53 PM
Edited Aug 7, 2007 at 9:44 PM
Hello there,

I am receiving the following error message.

Compilation Error
Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.

Compiler Error Message: CS0103

Source Error:

Line 6: {
Line 7: try {
Line 8: MyWebPagesStarterKit.WebSite.GetInstance();
Line 9: SiteMap.Provider.SiteMapResolve += new SiteMapResolveEventHandler(MyWebPagesStarterKit.Providers.CustomXmlSitemapProvider.Resolve);
Line 10: } catch (Exception ex)

Source File: f:\users\\httpdocs\Global.asax Line: 8

Could anyone help me. I am using the last version of "MyWebPagesStarterKit_1.1.2 Final".
It is starting to be frustrating.

The website run's perfectly on my local server (IIs 7.0), but I get the error message on the server of my hosting account
(Version Information: Microsoft .NET Framework Version:2.0.50727.832; ASP.NET Version:2.0.50727.832 )(IIs 6.0)

Thank you in advance for any help you could provide.

Great kit & Great forum.

It's ok I found my answer thank's any way.
Sep 30, 2007 at 6:04 PM
Please, I have the same problem on aspspider. Could you tell me how did you resolve the problem?

Thank you
Sep 30, 2007 at 8:09 PM

lanc71 wrote:
Please, I have the same problem on aspspider. Could you tell me how did you resolve the problem?

Thank you

Hello there,

Is it on a remote server or a local server.
Could please discribe the step you took to install the kit.
On which server? (IIs 6.00 or IIs 7.00)

Thank you
Sep 30, 2007 at 8:47 PM
It is on remote free server ( This is that I can read on the server:

Windows 2003 Server
.NET Framework 1.1
.NET Framework 2.0
SQL Server 2005 Express

Intel Pentium 4 dual processors
1 GB Memory

I can't see if they use IIS6 or II7.
This is what I done:
I have downloaded (from, than I have uploaded on in the file manager. So if I type I rea the error message.
Can you help me?
Sep 30, 2007 at 9:08 PM
Edited Sep 30, 2007 at 9:09 PM

There are several errors than comes under "error in / application". Most of the time it is because you need to have "read and write " access on the folder where your website reside.
Could tell me if you are trying to install the kit on the "/" of the server or in a subfolder?
Did you upload the folder of the starter kit to the server or did you upload the files only?

I will await your answer.

Sep 30, 2007 at 9:23 PM
This is an error that I see:


The final manager of "aspspider" has 2 folders: "webroot" a "database".

So, my root is "\lanc71\ webroot" and in this root I find the other folders "AppCode", " AppData ", "Bin" etc.
Does it mean something?

Sep 30, 2007 at 9:32 PM
I've tried to upload some simple file as "hello.aspx" in a folder \test\hello.aspx, and I see the same error.
I've tried to cancel the file "web.config" and I see the error again...
Sep 30, 2007 at 10:14 PM
Hi there,

Hold on I have just created an account on aspspider to test if I have read and write access on the folders.

I will be with in a minute.

Kind Regards
Sep 30, 2007 at 11:01 PM
Edited Sep 30, 2007 at 11:03 PM
Hi there,

I am back, I have tried to upload the kit without any success. It's telling me that the zip file cannot be more than 604.08MB. Very strange.

Well to come back to your problem,
If you do not have "write&read" access to you folders, you will get the error message.
If your website is in the wrong folder you will get the same message.

Secondly aspspider uses database so I don't think that the function "read&write" access is unable.

I give you an exemple:

web address:
I create a subfolder for a friend's website.
web address:

In your case it would be (" yourwebsite" refer to the root of the server for you).

Another thing I just seen, when you upload the site make sure you do not upload the "app data folder" nor the "web.config" file because they set up to work on their server.

If you want to use aspspider I recommend you to use a staterkit like the "club starter kit" the reason being that it uses database rather than XML file, and it is design to work on their server.

Hope this Help otherwise let me know.

Kind regards

Ps : If you want to see the starter kit in action look at http://armv26.cronowrek .com
Oct 1, 2007 at 6:12 AM
I have uploaded sharing the zip file in trhee part, becouse I had your same problem (the zip file cannot be more than 604.08MB).

Thank you

I've seen your work. Really good job.
Oct 1, 2007 at 8:14 AM
hi there,

thank you for your comment.

You should also check that you have all the files in the folders.

But if I were you I would just change hosting. Personnally I do not like the free hosting because you never have enough control for your website.

Kind regards,